Ultimate Rebel - Star Wars Lego

In the new version of Chrome (42) has been disabled support for plugin Unity3D, which is needed to play this game. But you can still activate it.
Detailed instructions how to activate Unity3D in Chrome, you can find here.
Or you can use another browser, such as Firefox, which will run this plugin properly.

Download Firefox